19.9.19.18 Crashing Site

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #25153
    John
    Participant

    I have UpDraft Plus 1.9.17.18 installed. It appears to be functioning normally. When I execute the update to 1.9.19.18, I lose the content on my HOME page. The HOME page appears blank except for the HEAD section. When I restore the site back to version 1.9.17.18, the site returns to normal and the UpDraft Plus update is still available. I’ve gone through this twice. The only other update available is “Media From http://FTP.”

    #25180
    udadmin
    Keymaster

    Hi John,

    That’s a bit odd, as there’s no version of UpdraftPlus that has any hooks into the front-end of WordPress (it doesn’t need any – the front end side is irrelevant to running back ups). I wonder if your site is running very close to your PHP memory limit, and if that’s it?

    Anyway – if the site crashes with HTML output ending prematurely, then there will be something logged in your PHP log – so have a read of that for entries at the relevant time. (PHP log, not Apache log).

    Best wishes,
    David

    #25190
    John
    Participant

    OK. Thanks, David. This keeps happening on my local editing WordPress site running on MAMP.

    Where do I find this this “PHP log” ?

    Where do I find my “PHP memory limit” ?

    How do I increase it, if necessary?

    Cheers,

    #25193
    John
    Participant

    I think I found the log file. Here is the relevant error:

    [21-Aug-2014 15:41:17 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 32 bytes) in /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-includes/wp-db.php on line 1941
    [21-Aug-2014 15:41:47 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 64 bytes) in /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-includes/meta.php on line 781
    [21-Aug-2014 15:42:10 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 64 bytes) in /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-includes/meta.php on line 781
    [21-Aug-2014 15:42:25 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 83 bytes) in /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-includes/wp-db.php on line 1941
    [21-Aug-2014 15:43:28 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 80 bytes) in /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-includes/wp-db.php on line 1941
    [21-Aug-2014 15:43:37 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 81 bytes) in /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-includes/wp-db.php on line 1941
    [21-Aug-2014 15:43:46 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 83 bytes) in /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-includes/wp-db.php on line 1941
    [21-Aug-2014 15:43:51 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 32 bytes) in /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-includes/meta.php on line 770
    [21-Aug-2014 15:43:52 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 32 bytes) in /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-includes/meta.php on line 778
    [21-Aug-2014 15:44:30 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 83 bytes) in /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-includes/wp-db.php on line 1941
    [21-Aug-2014 15:47:04 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 87 bytes) in /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-includes/meta.php on line 778
    [21-Aug-2014 15:48:56 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 81 bytes) in /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-includes/wp-db.php on line 1941
    [21-Aug-2014 15:49:05 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 81 bytes) in /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-includes/wp-db.php on line 1941
    [21-Aug-2014 15:51:12 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 32 bytes) in /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-includes/wp-db.php on line 1941
    [21-Aug-2014 15:52:05 UTC] s:103:”/Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-content/updraft”;
    [21-Aug-2014 15:52:05 UTC] a:0:{}
    [21-Aug-2014 15:52:05 UTC] s:0:””;
    [21-Aug-2014 15:52:05 UTC] /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-content/updraft
    [21-Aug-2014 16:22:07 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 81 bytes) in /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-includes/wp-db.php on line 1941
    [21-Aug-2014 16:22:34 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 80 bytes) in /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-includes/wp-db.php on line 1941
    [21-Aug-2014 16:23:00 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 80 bytes) in /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-includes/wp-db.php on line 1941
    [21-Aug-2014 16:24:11 UTC] PHP Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 83 bytes) in /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-includes/wp-db.php on line 1941
    [21-Aug-2014 16:24:24 UTC] s:103:”/Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-content/updraft”;
    [21-Aug-2014 16:24:24 UTC] a:0:{}
    [21-Aug-2014 16:24:24 UTC] s:0:””;
    [21-Aug-2014 16:24:24 UTC] /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-content/updraft
    [21-Aug-2014 16:30:36 UTC] s:103:”/Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-content/updraft”;
    [21-Aug-2014 16:30:36 UTC] a:0:{}
    [21-Aug-2014 16:30:36 UTC] s:0:””;
    [21-Aug-2014 16:30:36 UTC] /Users/jiko/Documents/MY DATA/JOHN_HEARTFIELD_COM/WWW/www/John-Heartfield-Exhibition/wp-content/updraft

    #25195
    John
    Participant

    David:

    Increased the PHP memory allocation in MAMP.

    Let’s see if that works.

    I’ll let you know.

    Thanks for pointing me in the right direction.

    )ohn

    #25202
    udadmin
    Keymaster

    Hi John,

    Great – that’s good to hear. To check that it’s taken effect, look in the expert/debugging tab in UpdraftPlus – it shows the memory settings there. I can see from your log that previously you only had 40Mb – which is way too low for a modern WP site (typical setting is 256Mb – not many sites avoid crashing on less than 80Mb or so).

    I don’t have a Mac, and hence have never used MAMP – so the question was one I could only have advised on by Googling in any case…

    Best wishes,
    David

    #25604
    John
    Participant

    David:

    That seemed to be the issue. I increased the PHP memory allocation and all’s well.

    If anyone else is using MAMP for Mac and wants to increase their PHP memory, this is a good page to simply explain it.

    http://lanche86.com/increase-php-memory-limit-mamp-pro/

    Make sure you check which PHP version you have.

    Cheers,

    )

    #25621
    udadmin
    Keymaster

    Hi John,

    Great – glad it’s working for you now.

    40Mb (as in the log files) is a much too low memory limit for 2014. Hopefully the MAMP people will raise it to something higher in the near future. 128Mb is really a bare minimum, from my experience of WP sites, to avoid a significant risk of unexpected out-of-memory conditions. 256Mb is the most common value seen on installed sites (81%).

    David

Viewing 8 posts - 1 through 8 (of 8 total)
  • The topic ‘19.9.19.18 Crashing Site’ is closed to new replies.