Failed to gain semaphore lock (fd)

UpdraftPlus Home Forums Paid support forum – UpdraftPlus backup plugin Failed to gain semaphore lock (fd)

This topic contains 3 replies, has 4 voices, and was last updated by  Dee Nutbourne 2 years, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #137199
    Charra
    Participant

    I get this error every time I attempt to back up the site.

    Failed to gain semaphore lock (fd) – another backup of this type is apparently already active – aborting (if this is wrong – i.e. if the other backup crashed without removing the lock, then another can be started after 3 minutes) (Dec 15 14:29:35)

    I use this plugin all of the time but occasionally I have this issue. When I build sites for my clients often I have to clone a Demo site (which also has Updraft installed and auto backing up each week) The new site will then have Updraft automatically installed in it and connected to the prior sites credentials. I always make sure to Wipe all settings under Advanced settings and then redo all of my settings and connection with Dropbox before I start the first backup. I am not sure if this has anything to do with it but wanted to mention it. I did follow your instructions for clearing all settings before attempting a backup so it should have worked. I use Updraft for many of my customers so I am very confident in it but this is probably the 5th time this has happened and I need to find a solution.

    Some of the things I tried:
    Clearing my Sites Cache
    Optimizing my Database
    Wiping my Settings
    Uninstalling and Reinstalling
    Reconnecting to my UpdraftPlus Account
    Debug Full Backup (Failed)
    Debug Database (Succeeded)

    All files & Logs can be found here: (snipped)

    My Order# is Order #107642 was placed on April 6, 2015 and is currently Completed.

    Please help!

    • This topic was modified 8 months, 4 weeks ago by  Charra.
    #137257
    udadmin
    Keymaster

    Hi Charra,

    I can see that there’s a ticket with identical content in our ticket system, that’s had a reply from one of our staff – so, please let’s carry on the conversation there. (Please don’t double-post issues – it makes us go slower, not faster!).

    David

    #233821
    Jordi
    Participant

    Hi, i have the same problem, but i can not find the other ticket with the same content. Could you help me to solve this issue?

    thank you in advance

    #234242
    Dee Nutbourne
    Moderator

    Hi Jordi,

    What version of UpdraftPlus is currently installed?

    Does the same issue occur if you start a backup of the database only?

    Best Wishes,
    David N

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Failed to gain semaphore lock (fd)’ is closed to new replies.