Migration Worked – But Not Images

UpdraftPlus Home Forums Paid support forum – UpdraftPlus backup plugin Migration Worked – But Not Images

Tagged: ,

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #17937
    seakiteair
    User

    Hello –

    First of all, Wow – what a brilliant plug-in. Thank you!

    I purchased the migration plug-in, and my site migrated beautifully. However, the images do not show on the new (migrated) version of the site.

    The old site is still at the URL http://www.calebkeiter.com

    The new site I migrated to is temporarily at http://66.147.244.74/~calebkei/

    Why did the images not make it? I checked all of the boxes.

    Thanks,

    #18147
    seakiteair
    User

    Update – I checked my Media tab in WordPress, and all of the listings of the images show up, but all of the images are broken. Thoughts?

    #18148
    seakiteair
    User

    Final question for now, sorry.

    I am migrating the site to a new host, though I am keeping the same domain name (www.calebkeiter.com). Once the migration is complete and I get the images figured out, I will need to change the name servers at GoDaddy to the new host. Once I change the name servers, how do I update my WordPress database, or do I need to? Right now, all of the links point to the temporary domain of http://66.147.244.74/~calebkei.

    Thanks again! I still cannot believe how easy this plug-in made moving my site. There are far fewer hiccups than I expected.

    Caleb

    #18149
    udadmin
    Keymaster

    Hi Caleb,

    I’m looking at the image in the top left – this has URL: http://66.147.244.74/~calebkei/wp-content/uploads/2012/04/caleb-keiter-photography-logo-color-small.png. So that’s pointing to the correct place on the new site.

    But when I try to fetch that, I get:

    –2013-08-02 01:01:25– http://66.147.244.74/~calebkei/wp-content/uploads/2012/04/caleb-keiter-photography-logo-color-small.png
    Connecting to 66.147.244.74:80… connected.
    HTTP request sent, awaiting response…
    HTTP/1.1 301 Moved Permanently
    Date: Fri, 02 Aug 2013 00:01:25 GMT
    Server: Apache
    X-Pingback: http://66.147.244.74/~calebkei/xmlrpc.php
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Cache-Control: no-cache, must-revalidate, max-age=0
    Pragma: no-cache
    Set-Cookie: PHPSESSID=jip3kbpa18kv65g0pkckuf6k87; path=/; HttpOnly
    Location: http://66.147.244.74/~calebkei
    Vary: Accept-Encoding
    Content-Length: 0
    Keep-Alive: timeout=10, max=30
    Connection: Keep-Alive
    Content-Type: text/html; charset=UTF-8

    I’m not sure if that means much to you – but basically the web server is saying “Go here instead to get that: http://66.147.244.74/~calebkei” – which doesn’t work, of course (there’s no image at that URL directly). The question is, why is the webserver doing that? Have you got some manual redirection instructions somewhere?

    Do this: try temporarily (or permanently) removing the .htaccess file (if any) in the root directory of the site. After you’ve done that, reload the front page. If it works, then you may find that other pages don’t work until you go into the dashboard (http://66.147.244.74/wp-admin) and go into Options -> Permalinks and re-save.

    It’s the end of the day here, so please excuse the lack of replies after this one until tomorrow!

    David

    #18150
    udadmin
    Keymaster
    Quote:
    I will need to change the name servers at GoDaddy to the new host. Once I change the name servers, how do I update my WordPress database, or do I need to? Right now, all of the links point to the temporary domain of http://66.147.244.74/~calebkei.

    You can use this plugin – http://wordpress.org/plugins/search-and-replace/ – to search-and-replace.

    Search for: http://66.147.244.74/~calebkei
    Replace with: http://whateveryourdomainis.com

    Glad you find UD useful!

    Best wishes,
    David

    #18151
    seakiteair
    User

    Thanks for the Search and Replace recommendation.

    I had a redirect plug-in active. However, I made that plug-in Inactive and the images still could not load.

    I checked the server, and there are no files in the /wp-content/uploads directory. I tried restoring the Uploads zip file to the new site two more times, but it failed both times saying the file sizes did not match.

    So, I am uploading the .zip file into the new site again and will try to restore once it is finished. I will report back.

    In the meantime, is there anything else I should look at?

    #18153
    udadmin
    Keymaster

    Hi,

    Presently, UpdraftPlus only warns – doesn’t abort – if the backup archive is an unexpected size. So, if nothing restores, then presumably the zip isn’t uploading correctly, or is empty. You can FTP it manually into wp-content/updraft, and then press the “Rescan” link in the restore section… but do first check on its contents manually on your PC (by unzipping it).

    Did you check out whether you have a .htaccess file in the root directory of your WP install? You may need to find the “show hidden files” option in your FTP program, as often they’re not shown by default if they begin with a period.

    David

    #18165
    seakiteair
    User

    I re-downloaded my Uploads.zip from the original site, and re-uploaded it into Updraft in the new site and it worked this time. There must have been something wrong with the original .zip file.

    Thanks for walking me through it! Great product and great support!

    #18166
    udadmin
    Keymaster

    You’re welcome!

    David

    #254413
    joanne
    Participant

    I have a similar problem. But I no longer have the original site live. I have 2 backups and neither will open and restore the UPLOADS folder. SO the site is active with no images. Only placeholders for images. How can I access the images in the zip backup file to more accurately restore the site?

    drmanges.com

    #254654
    Dee Nutbourne
    Moderator

    Hi @joanne,

    I’m afraid that corrupted zips cannot be opened.

    If you have another copy of the backup files stored in remote storage, I would recommend trying to download the files directly from there, and attempt to restore manually.

    Best Wishes,
    David N

    #319884
    kevin.brown
    Participant

    This happened to me. I figured out it was a problem with the “Adaptive Images for WordPress” plugin. It wasn’t finding the right images in the cache. It worked once I disabled the plugin, and then fixed for good once I used the “Cleanup Cache” function on the plugin’s settings page. If you have any plugins that relate to image processing or optimization I suggest disabling them temporarily to troubleshoot, then look to see if there is a way to fix the cache. Good luck!

Viewing 12 posts - 1 through 12 (of 12 total)
  • The topic ‘Migration Worked – But Not Images’ is closed to new replies.