There has been a critical error on this website

UpdraftPlus Home Forums Paid support forum – UpdraftPlus backup plugin There has been a critical error on this website

Tagged: 

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #1178572
    Peter Cunningham
    Participant

    Hi -I have tried to do a restore from a temporary domain to a different webhost and domain. I have done this many times but not with this new web host.
    The restore said it was successful however the site isnt working –

    “There has been a critical error on this website. Please check your site admin email inbox for instructions.”

    Learn more about troubleshooting WordPress.

    If you see this message after saving the snippet to the Woody ad snippets plugin, please enable safe mode in the Woody plugin. Safe mode will allow you to continue working in the admin panel of your site and change the snippet in which you made a php error.

    there was a notice on the log to say this –
    “Warning: Your website is hosted using the LiteSpeed web server. Please consult this FAQ if you have problems backing up.”

    Any advice would be appreciated –

    new domain is –
    https://demo.bathroomexcellence.ie/

    old domain is –

    Homepage

    #1178573
    Peter Cunningham
    Participant
    This reply has been marked as moderator-only.
    #1178621
    send2ds
    Participant

    Same problem here. Updating the plugin caused a fatal error killing the site.

    Version 2.16.59.25 failed to load properly.

    Warning: require_once(/var/www/vhosts/(my website)/httpsdocs/wp-content/plugins/updraftplus/options.php): failed to open stream: No such file or directory in /var/www/vhosts/(my website)/httpsdocs/wp-content/plugins/updraftplus/updraftplus.php on line 219

    Fatal error: require_once(): Failed opening required ‘/var/www/vhosts/(my website)/httpsdocs/wp-content/plugins/updraftplus/options.php’ (include_path=’.:/opt/plesk/php/7.2/share/pear’) in /var/www/vhosts/(my website)/httpsdocs/wp-content/plugins/updraftplus/updraftplus.php on line 219

    WordPress version 5.7.2
    Current theme: OceanWP (version 2.1.0)
    Current plugin: UpdraftPlus – Backup/Restore (version 2.16.59.25)
    PHP version 7.2.34

    Error Details
    =============
    An error of type E_COMPILE_ERROR was caused in line 219 of the file /var/www/vhosts/(my website)/httpsdocs/wp-content/plugins/updraftplus/updraftplus.php.

    I disabled the plugin and am attempting to restore the site in recovery mode.

    • This reply was modified 2 months ago by send2ds.
    #1178632
    send2ds
    Participant

    Site is restored by disabling UpdraftPlus.

    #1178646
    Bryle Crodua
    Moderator

    Hi,

    Can you try to upgrade the PHP version to 7.3?
    Do you still get a critical error?

    Thanks,
    Bryle

    #1178789
    send2ds
    Participant

    Thanks. Will request that option with my host and give it a try. Will get back to you but could take a few days. :)

    #1179210
    Peter Cunningham
    Participant

    hi – i managed to get it working by renaming the plugins folder and reactivating one plugin at a time.
    However the import didnt quite work as some of the products photos and media library are still referencing the old test URL.
    i will do it manually – thanks for your advice anyway.

    #1192501
    send2ds
    Participant

    Can you try to upgrade the PHP version to 7.3?
    Do you still get a critical error?

    I upgraded to 7.4.22 and get the fatal error. (PHP 7.3 is not an option.) At least it doesn’t crash the site, but I have no backup resource b/c UpdraftPlus is disabled. I’m on WP v. 5.7.2 but don’t want to try updating to WP 5.8 w/o backup.

    #1192506
    send2ds
    Participant

    (My edit didn’t post)

    My identical test site is on WP 5.8, PHP 7.2.34, Updraft v2.16.59.1. Everything is fine there.

    So I don’t know how to proceed. If Updraft v2.16.59.25 gives a fatal error with PHP 7.4.22 on the live site, I don’t know where to begin to sort this on the test site where I do have an active Updraft plugin for backup.

    • This reply was modified 1 month, 2 weeks ago by send2ds.
    #1193121
    Dee Nutbourne
    Moderator

    Hi Both,

    Apologies for the ongoing inconvenience.

    Please could you check the wp-content/plugins/updraftplus directory of your site, and check if a file named options.php is present?

    If not, please could you remove the UpdraftPlus plugin directory, and reinstall UpdraftPlus from a fresh download?

    Best Wishes,
    Dee

    #1193343
    send2ds
    Participant

    Thank you, Dee.

    Before seeing your reply, I deactivated Updraft, updated PHP to 7.2.34, then replaced Updraft with a version downloaded from this site. Of course I wasn’t able to check if “options.php” existed. It was present in the duplicate test site on the same server, however. On the duplicate site I updated PHP and Updraft in a similar fashion. So whatever cobwebs were living in the troublesome live site, they seem to have disappeared. :)

    Thank, again.

    don

    #1193432
    Colin Blunt
    Participant

    I too am getting this error, I’ve drop the database, removed wordpress and re-installed then tried to rebuild wp and then the add in updraftplus, I’m now going back to backupset from 27th as all recent ones fail

    #1193439
    Colin Blunt
    Participant

    No luck I’m afraid, this was my last successfully working restore point, and now word press asks me to login but I get the error.
    “here has been a critical error on this website. Please check your site admin email inbox for instructions.

    Learn more about troubleshooting WordPress.”

    #1193447
    Colin Blunt
    Participant

    I can access webserver via ssh and call also see the wordpress mariandb I’ve been dropping it though and re-creating it along with the

    apache2
    cd /var/www/html/
    sudo rm -r *

    like I said after re-install this last time at least it asked me for a wordpress login.

    Let me know if you need log files.

    #1193452
    Colin Blunt
    Participant

    php -version
    PHP 7.3.29-1~deb10u1

Viewing 15 posts - 1 through 15 (of 19 total)
  • The topic ‘There has been a critical error on this website’ is closed to new replies.