Unable to connect to SFTP on Synology NAS

UpdraftPlus Home Forums Paid support forum – UpdraftPlus backup plugin Unable to connect to SFTP on Synology NAS

Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts
  • #1229465
    paul.b
    Participant

    I’m trying to send backups via sftp to a Synology NAS. I’ve opened a custom port on the router to a custom port on the NAS and that port is defined in File Services > FTP > SFTP > Port Number.

    The user name and credentials are correct in Updraft as is the port and server name.

    When I test the connection in Updraft it errors out with

    SFTP settings test result: Failed: SSH 2 login failed
    Messages:
    * PHP event: code E_USER_NOTICE: Cannot connect to https//xxxxxxxxxxx,dsmynas.org:5023. Error 32721. Unable to find the socket transport “https” – did you forget to enable it when you configured PHP? (line 1201, wp-content/plugins/updraftplus/vendor /phpseclib/phpseclib/phpseclib/Net/SSH2.php)
    OK

    I’d be grateful for some clarification please. I don’t recall having to configure php for Updraft?

    #1229466
    paul.b
    Participant
    This reply has been marked as moderator-only.
    #1230510
    Bryle Crodua
    Moderator

    Hi,

    Please could you check if you have the SFTP for PHP extension configured?

    If yes, it could be a firewall issue, please check with your hosting support if they allow outgoing SFTP connections.

    Regards,
    Bryle

    #1232159
    paul.b
    Participant

    Thanks Bryle

    I’m having a senior moment

    My account is connected and I see the All Addons box visible but it’s been a couple of years since since I’ve been into this section and I can’t see all the individual extensions listed as I used to (I think!)

    So where do I configure the extension please?

    #1232798
    Bryle Crodua
    Moderator

    Hi Paul,

    The last digit in a 4-part version number is the number of installed add-ons. If you have 2.16.61.0, that means you have 0 add-on/s installed.

    The most common values are:

    .0 – No add-ons installed
    .1 – A single add-on installed
    .25 – All add-ons installed (Full Premium)

    To activate the add-ons, this is done by entering your username and password in the “Premium/Extensions” tab.
    After that you should see an update link from UpdraftPlus. Click on the link to update and it will install the add-ons.
    The final version should be 2.16.61.25.

    I’m not yet senior but I get that moments too! :D

    Thanks,
    Bryle

    #1232868
    paul.b
    Participant

    Screenshot

    So, what next, please? I am definitely missing something here!! :)

    Paul

    • This reply was modified 2 months, 2 weeks ago by paul.b.
    #1233049
    Bryle Crodua
    Moderator

    Hi Paul,

    You can ignore that message. You are all sent based on the screenshot and plugin version.

    Thanks,
    Bryle

    #1233999
    paul.b
    Participant

    My host says there’s no issue with sftp from the server so that means it’s Updraft or the target server. But that error message talked about an error in configuring Updraft. Why is it generating that message please?

    #1234359
    Bryle Crodua
    Moderator

    Hi Paul,

    I just want to clarify, are you still getting this error message?
    * PHP event: code E_USER_NOTICE: Cannot connect to https//xxxxxxxxxxx,dsmynas.org:5023. Error 32721. Unable to find the socket transport “https” – did you forget to enable it when you configured PHP? (line 1201, wp-content/plugins/updraftplus/vendor /phpseclib/phpseclib/phpseclib/Net/SSH2.php)

    Regards,
    Bryle

    #1234481
    paul.b
    Participant

    Yes

    #1234519
    Udo Neumann
    Participant

    Paul, I used it without issues on my Synology without issues

    I used the Synology hostname xxxx.sysnology.me on port 22 and created an RSA fingerprint – worked like a charme

    #1234613
    paul.b
    Participant

    Hi Udo

    That’s good to hear. I’m not using the default port – I rarely do – but please could you tell me more about the RSA fingerprint

    #1236324
    paul.b
    Participant

    Udo. If you’re on port 22 that’s ftp not sftp, right? My hosting company doesn’t allow external connection over ftp

    #1236325
    paul.b
    Participant

    Hi Bryle

    Any futher news for me please?

    #1243893
    paul.b
    Participant

    Hi Bryle

    I’m becoming desperate for a solutiom. I’m having to manually transfer files st the moment.

Viewing 15 posts - 1 through 15 (of 22 total)
  • The topic ‘Unable to connect to SFTP on Synology NAS’ is closed to new replies.