Are you seeing a warning about which versions of WordPress UpdraftPlus has been tested on?

Are you are seeing a warning in your WordPress dashboard that’s something like this?

Warning: The installed version of UpdraftPlus has not been tested on your version of WordPress (4.5.3). It has been tested up to version 4.3. You should update UpdraftPlus to make sure that you have a version that has been tested for compatibility.

If so, then you should definitely update your installed version of UpdraftPlus. Though the WordPress developers work very hard on trying to make releases of WordPress to be backwards-compatible with previous releases, this is not guaranteed. A backup plugin, like UpdraftPlus, often wants to go quite deep into WordPress. And, of course, reliable backups are vital. This message is shown to minimise the risk of your having deficient backups when you need them.

To update UpdraftPlus to the latest release, visit the page Dashboard -> Updates from your WordPress dashboard menu (at or near the top).

Alternatively, if your access to UpdraftPlus updates has expired, then you should renew.