Cannot update

Tagged: ,

This topic contains 8 replies, has 2 voices, and was last updated by  Pádraig 2 years, 8 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #181317
    Pádraig
    Participant

    The following problem was experienced on the free version and also three different servers hosting the paid version. When I go to the Update Plugins section in my dashboard admin and tick to update the plugin from 2.12.25 to 2.12.27 I just get the following unending message…
    —begin—
    The update process is starting. This process may take a while on some hosts, so please be patient.

    Enabling Maintenance mode…

    Updating Plugin UpdraftPlus – Backup/Restore (1/1)
    —end—
    It also happens with the free version and I’ve posted a support topic there as well. Hope that’s ok. I have to delete the .maintenance file in root to regain access to the site. Thanks for your help. This is the first time in over two years that I’ve had a problem.

    #181335
    Dee Nutbourne
    Moderator

    Hi,

    Please could you (or your hosts) check the PHP error logs? Are there any errors present that are related to either UpdraftPlus or the WordPress updates page?

    Best Wishes,
    David N

    #181347
    Pádraig
    Participant

    Hi David,

    Thanks for the prompt reply. My error log shows:

    [Tue Nov 22 15:31:57 2016] [error] [client 87.37.31.243] ap_content_length_filter: apr_bucket_read() failed, referer: http://www.gortskehy.com/wp-admin/update-core.php?action=do-plugin-upgrade
    [Tue Nov 22 15:31:57 2016] [error] [client 87.37.31.243] ap_pass_brigade failed with error 70007: The timeout specified has expired, referer: http://www.gortskehy.com/wp-admin/update-core.php?action=do-plugin-upgrade

    I can’t imagine the file size would have increased dramatically with recent updraft updates (since 2.12.15). For the past two years it’s worked fine. Also, I didn’t install any other plugins in the last couple of months. It’s the only plugin where this has started happening. I use Nextscripts Social Share which would be hefty enough but it updates fine. Maybe the error log above will give you a clue as to what’s happening.

    Thanks,

    Pádraig

    #181509
    Dee Nutbourne
    Moderator

    Hi Pádraig,

    Could you ask your hosts if the Apache TimeOut directive can be increased?

    It is possible that the UpdraftPlus plugin file has increased to the size where it is taking just over the time limit to process.

    Best Wishes,
    David N

    #182757
    Pádraig
    Participant

    Thanks for the prompt support David,

    My host increased the Apache Timeout length on all of my three accounts but it didn’t make any difference. They also have a good reputation (Blacknight) and I’ve never had any timeout issues despite having 20 plugins of various sizes. I don’t mind updating via ftp if that’s the only solution. The strange thing is that I have 2.12.27 and the 2.12.29 update is not showing in any of my website admin panels, even on localhost. If I download the zip from https://updraftplus.com/support/installing-updraftplus-premium-your-add-on/ it’s version 2.12.27 but on the WordPress Updraft plugin page the latest version is 1.12.29 https://downloads.wordpress.org/plugin/updraftplus.1.12.29.zip
    Is it ok to update my premium plugin via ftp with the 1.12.29 from the WP plugin depository? Will it keep my settings?

    Many thanks,

    Pádraig

    #182916
    Dee Nutbourne
    Moderator

    Hi Pádraig,

    The free and Premium versions of UpdraftPlus have become slightly out-of-sync due to a free version-only error that required an emergency patch. The latest version of UpdraftPlus Premium is 2.12.27.

    Could you ask your hosts if the server uses FastCGI? If so, can they adjust the time out configuration for FastCGI?

    Best Wishes,
    David N

    #182982
    Pádraig
    Participant

    Hi David,

    Yes, all my accounts run on FastCGI. The host can make changes to it but would like to know “what specific value would you like changed and what do you need it set to?”

    Many thanks,

    Pádraig

    #183071
    Dee Nutbourne
    Moderator

    Hi Pádraig,

    Your hosts will need to check the following:

    • the FcgidIOTimeout value in fcgid.conf
    • the FastCGI ActivityTimeout parameter

    I’m afraid that I cannot give an exact amount to increase these by, but I would recommend doubling the current value to start with.

    Best Wishes,
    David N

    #183981
    Pádraig
    Participant

    Hi David,
    My host has checked and increased timeouts on php 5.3 fastcgi. Tried updating on that php version but still didn’t work. Also tried php 7 but no joy. I have reverted back to my default php version 5.6 and will update by ftp from now on. Thanks again for your prompt support.
    All the best,
    Pádraig

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Cannot update’ is closed to new replies.